Das nächste Entwicklertreffen findet Anfang Mai in Münster statt - weitere Infos bzw. zur Anmeldung!

Suchen im Forum

Vorschläge, Infos, Verbesserungen, Technisches

Moderator: Moderatoren

Antworten
Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 18200
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Suchen im Forum

Beitrag von Manfred » So, 19. Okt 2008 14:56

Tach,

zwischendurch aktualisere ich immer wieder den Forenindex. Dabei kommt es natürlich auch häufiger vor, dass ich Suchen muß um möglichst viele Daten im Index zu erfassen.

Im Moment bin ich aber sehr verwirrt, weil ich überhaupt nicht mit dem Suchteil des Forums klar komme.

Ich suche Beiträge, die sich mit DLL beschäftigen.

Gebe ich nur DLL ein, dann erscheint die Meldung dass zu viele Ergebnisse gefunden wurden und ich doch bitte mehr eintippen soll.

Gut, mache ich es anders. Ich tippe +dll +dynamisch ein.

Was kommt als Ergebnis?

Benutzte Suchanfrage: +dll +dynamisch ignoriert: dll

Watt soll der Quatsch? Wenn ich dll an 2. Stelle setze, dann wird es auch ignoriert.

Ich will Beiträge finden, in denen dynamisch UND dll vorkommt.
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 11547
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Suchen im Forum

Beitrag von AUGE_OHR » So, 19. Okt 2008 15:26

hi,
Manfred hat geschrieben: Ich will Beiträge finden, in denen dynamisch UND dll vorkommt.
tja das "richtige" Stichwort fehlt.
Wenn du eine DLL "benutzten" will die "dynamische geladen" wird dann würde ich nach:
DLLload() suchen.
gruss by OHR
Jimmy

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 18200
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: Suchen im Forum

Beitrag von Manfred » So, 19. Okt 2008 15:33

Hi Jimmy,

bist Du Dir jetzt sicher, dass wir beide von der gleichen Sache reden?

Ich weiß, dass meine Beiträge hier bzgl. DLL kein load() haben. Es sollte auch nur als Beispiel dienen. Ich wollte nur Beiträge finden hier im Forum, die DLL haben. Da dieser Suchbegriff zu kurz ist, habe ich +dynamisch hinzugefügt. Dabei wurde aber dann DLL ignoriert. Eigentlich wollte ich nach den Begiffen DLL DYNAMISCH STATISCH STATIC DYNAMIC suchen, weil ich mich erinnert habe, dass die zumindest irgendwo passend dazu aufgetaucht sind. Aber es klappte nicht. DLL muß sein , der Rest kann sein. Nur damit es nicht zu viel werden.

Aber es geht darum, dass die Kombination so nicht akzeptiert wird. DLL alleine will das Forum aber auch nicht haben.
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite

Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 14597
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Kontaktdaten:

Re: Suchen im Forum

Beitrag von Martin Altmann » So, 19. Okt 2008 16:22

Manfred,
das liegt daran, dass die Mindestlänge für einen Suchbegriff bei 4 Zeichen liegt :D
Hat Tom mal so konfiguriert. Könnte latürnich auch auf 3 verkürzt werden...
Du könntest aber auch mal nach DLL* suchen - sind vier Zeichen und funzt :wink:
Und lass Dich nicht von der Fehlermeldung beim Suchen ins Boxhorn jagen...

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 18200
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: Suchen im Forum

Beitrag von Manfred » So, 19. Okt 2008 16:25

Martin,

das sie bei 3 Zeichen lag, hatte ich mir schon gedacht. Aber Shit, das mit dem * klappt. War mal wieder zu einfach für mich, bzw. ich dachte wohl, dann.... Was dachte ich eigentlich? Ich denke mal nichts.

Danke, das hilft mir jetzt weiter.
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 11547
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Suchen im Forum

Beitrag von AUGE_OHR » Mo, 20. Okt 2008 3:11

hi,
Manfred hat geschrieben: bist Du Dir jetzt sicher, dass wir beide von der gleichen Sache reden?
scheinbar nicht. Für mich sind "dynamische" DLL diejenigen bei den ich DllLoad() / DllUnload() benutze. Wenn ich eine DLL, als LIB miteinlinke, muss ich die nicht "nachladen" also nicht dynamisch.
gruss by OHR
Jimmy

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 18200
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: Suchen im Forum

Beitrag von Manfred » Sa, 15. Nov 2008 14:15

Hi,

wieder was, was ich nicht verstehe. Hat schon mal jemand nach dem Begriff "Thread" gesucht?

Dann kommen über 1000 Ergebnisse. Also, da ja eigentlich "Thread(" oder "Thread()" gemeint ist, wird die Suche danach wiederholt. Der Begriff taucht aber gar nicht auf. Watt nu?
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite

Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 14597
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Kontaktdaten:

Re: Suchen im Forum

Beitrag von Martin Altmann » Sa, 15. Nov 2008 16:24

Hallo Manfred,
ganz einfach - such mal nach Thread\(
Du musst die Klammer einfach "escapen" - dann geht es :-)

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 18200
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: Suchen im Forum

Beitrag von Manfred » Sa, 15. Nov 2008 16:30

Hi Martin,

schade, kein guter Einfall. :badgrin:

Such mal nur Thread und suche mal Thread\(.

Das Ergebnis ist das gleiche.

Das meinte ich mit meiner Anmerkung.
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 11547
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Suchen im Forum

Beitrag von AUGE_OHR » So, 16. Nov 2008 7:16

hi,
und was wäre mit
Thread* -> 1091
...
zumindest sind die Begriffe "gelb" eingefährt
gruss by OHR
Jimmy

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 18200
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: Suchen im Forum

Beitrag von Manfred » So, 16. Nov 2008 9:44

Hi,

ihr macht mich alle traurig. Keiner versteht mich.... :cry:

Ich möchte nicht nach dem Begriff "Foren Thread" suchen, sondern nach der Klasse Thread. Wenn ich aber Thread alleine eintippe dann bekomme ich in der Tat über 1000 Einträge, die auch gelb unterlegt sind. Aber die will ich ja gar nicht alle haben. Ich möchte Thread mit mindestens "(" dahinter, aber das klappt mit der Suche nicht.
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 11547
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Suchen im Forum

Beitrag von AUGE_OHR » So, 16. Nov 2008 10:03

hi,
Manfred hat geschrieben:Ich möchte Thread mit mindestens "(" dahinter, aber das klappt mit der Suche nicht.
aber genau das "(" geht doch nicht zu suchen ...
wie wäre : +Thread +:New
gruss by OHR
Jimmy

Benutzeravatar
Manfred
Foren-Administrator
Foren-Administrator
Beiträge: 18200
Registriert: Di, 29. Nov 2005 16:58
Wohnort: Kreis Wesel

Re: Suchen im Forum

Beitrag von Manfred » So, 16. Nov 2008 10:09

Sag ich doch....
Gruß Manfred
Mitglied der XUG Leverkusen
Mitglied der XUG Osnabrück
Schatzmeister des Deutschsprachige Xbase-Entwickler e.V.
großer Fan des Xbaseentwicklerwiki https://wiki.xbaseentwickler.de/index.p ... Hauptseite

UliTs
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2543
Registriert: Fr, 10. Feb 2006 9:51
Wohnort: Aachen
Kontaktdaten:

Re: Suchen im Forum

Beitrag von UliTs » Di, 29. Nov 2011 10:24

Ich bin auch kläglich bei der Suche nach z.B. Thread() gescheitert!
Gibt es inzwischen eine Möglichkeit, nach beliebigen Zeichen zu suchen?
ich habe schon 'Thread()', 'Thread\(\)' versucht.
Uli
-------
Mitglied XuG Cologne
Mitglied XuG Osnabrück

Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
Beiträge: 14631
Registriert: Mo, 23. Jan 2006 20:54
Wohnort: Germersheim
Kontaktdaten:

Re: Suchen im Forum

Beitrag von brandelh » Di, 29. Nov 2011 11:52

Hi,

wie es scheint sind ( und ) Sonderzeichen und werden bei der Suche ausgeblendet.

Thread und Thread* finden das Gleiche ...
Gruß
Hubert

Benutzeravatar
Koverhage
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2091
Registriert: Fr, 23. Dez 2005 8:00
Wohnort: Aalen
Kontaktdaten:

Re: Suchen im Forum

Beitrag von Koverhage » Di, 17. Jun 2014 12:20

wie finde ich
GraQueryTextBox ?
Gruß
Klaus

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13159
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Suchen im Forum

Beitrag von Jan » Di, 17. Jun 2014 12:35

Indem Du das in die Suchfunktion eingibst.

Nein, im Ernst: Ich habe das eben mal gemacht, und erhalte eine Vielzahl von Treffern (inkl. Deiner Frage). Ist das bei Dir anders?

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Koverhage
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2091
Registriert: Fr, 23. Dez 2005 8:00
Wohnort: Aalen
Kontaktdaten:

Re: Suchen im Forum

Beitrag von Koverhage » Di, 17. Jun 2014 15:43

Jan,

jetzt geht das bei mir auch, merkwürdig.

Aber ich hatte auch nach graq gesucht, und habe weder vorhin noch jetzt etwas gefunden.
Gruß
Klaus

Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
Beiträge: 14631
Registriert: Mo, 23. Jan 2006 20:54
Wohnort: Germersheim
Kontaktdaten:

Re: Suchen im Forum

Beitrag von brandelh » Di, 17. Jun 2014 20:06

bei TEILBEGRIFFEN muss man * an die fehlende Seite anhängen ;-)
Gruß
Hubert

Antworten