CURL.EXE Windows 10/11 und WEB.DE [erledigt]

Konzeptionelles, Technisches, Termine, Fragen zum Hersteller usw.

Moderator: Moderatoren

Antworten
Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12754
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg
Hat sich bedankt: 15 Mal
Danksagung erhalten: 20 Mal

CURL.EXE Windows 10/11 und WEB.DE [erledigt]

Beitrag von AUGE_OHR »

hi,

ich versuche CURL.EXE für EMAIL zu verwenden.
Das klappt mit T-ONLINE.DE :)

---

wenn ich nun mit CURL.EXE , von T-Online.DE, eine Mail an WEB.DE schicke

Code: Alles auswählen

CURL.EXE -# --insecure  --ssl-reqd --url smtps://securesmtp.t-online.de:465 --user YYYYYYYY@t-online.de:xxxxxxx --mail-from YYYYYYYY@t-online.de --mail-rcpt ZZZZZZZZ@web.de --stderr G:\minigui\Samples\Applications\SendMail2\CurlReply.txt --upload-file G:\minigui\Samples\Applications\SendMail2\Template.eml
erhalte ich
The mail system

<ZZZZZZZZ@Web.DE>: host mx-ha02.Web.DE[212.227.17.8] said: 554-Transaction
failed 554-Reject due to policy restrictions. 554 For explanation visit
https://web.de/email/senderguidelines?i ... 34.81&c=hi (in reply to
end of DATA command)

so sieht das *.EMF aus

Code: Alles auswählen

From: YYYYYYYY@t-online.de <YYYYYYYY@t-online.de>
To: <ZZZZZZZZ@web.de>
Subject: blaaa
Reply-To: YYYYYYYY@t-online.de <YYYYYYYY@t-online.de>
X-Mailer: Harbour and Curl by Pierpaolo Martinello
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="---=__Part__918c2c566b367e199de1eb7b"

-----=__Part__918c2c566b367e199de1eb7b
Content-Type: multipart/alternative;
 boundary="---=__Part__2c1a928c918c2c566b367e19"

-----=__Part__2c1a928c918c2c566b367e19
Content-Type: text/plain; charset="UTF-8" 
Content-Transfer-Encoding: quoted-printable

von T-ONLINE an ZZZZZZZZ=40WEB.DE


-----=__Part__2c1a928c918c2c566b367e19
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 8bit

<html>
 <head>
  <meta http-equiv="content-type" content="text/html; charset=UTF-8">
 </head>
 <body> <p>
von T-ONLINE an ZZZZZZZZ@WEB.DE<br>
 <br>
  </p>
 </body>
</html>
-----=__Part__2c1a928c918c2c566b367e19--
-----=__Part__918c2c566b367e199de1eb7b--
Frage : "was" sagt mir die Fehler Meldung und "was" soll / muss ich verändern für WEB.DE :?:
Zuletzt geändert von AUGE_OHR am Di, 05. Jul 2022 6:41, insgesamt 1-mal geändert.
gruss by OHR
Jimmy
Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 14381
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Hat sich bedankt: 19 Mal
Danksagung erhalten: 57 Mal
Kontaktdaten:

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von Jan »

Jimmy,

554 ist bei web.de grob die Aussage
- das der Empfänger-Provider die Mail als Spam eingestuft hat
- das Technische Fehler in der Mail bestehen (z. B. mehr als ein Absender, mehr als ein Empfänger, mehr als ein Datum, usw.)
- das in zu kurzer Zeit zu viele Mails aus dem sendenen Mailserver als Spam identifiziert wurden

Eine Checkliste hat web.de ja auch geliefert unter dem Link, den Du mit gepostet hast.

Mir fehlt in der Rückgabe von web.de ein wenig Infos. Normalerweise schreiben die da doch mehr rein wo das Problem liegt, nicht so allgemein.

Mit curl habe ich nie gearbeitet, kann da also eher weniger zu sagen ob das alles so passt. Wobei das ja wie Du schreibst bei Mails an T-Online klappt, wirklich falsch kann das also nicht sein. Wobei das dann ja auch von T-Online an T-Online geht, vielleicht "reparieren" die da intern ein ein paar ansonsten nicht zulässige Ungenauigkeiten. Vielleicht kannst Du mal ein paar andere Kombinationen von Absender- und Empfänger-Providern testen.

Passen denn die Angaben --ssl-reqd und Port 465 zusammen? Wie gesagt, ich kenne curl und dessen Parameter nicht

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.
ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2415
Registriert: Mi, 28. Jul 2010 17:16
Hat sich bedankt: 11 Mal
Danksagung erhalten: 52 Mal

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von ramses »

Versuche mal diese Zeile aus dem Header zu entfernen:
X-Mailer: Harbour and Curl by Pierpaolo Martinello
Ich hatte das einmal dass die Angabe in dieser Zeile den "Spam-Fehler" verursachte.
Valar Morghulis

Gruss Carlo
Dominik Krebs
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 135
Registriert: Mo, 15. Apr 2019 16:19
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von Dominik Krebs »

Ich finde ja cmail ganz gut.
https://www.inveigle.net/cmail
Gruß Dominik
Benutzeravatar
Werner_Bayern
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2008
Registriert: Sa, 30. Jan 2010 22:58
Wohnort: Niederbayern
Hat sich bedankt: 20 Mal
Danksagung erhalten: 43 Mal

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von Werner_Bayern »

Jimmy,

was hältst du davon, endlich mal all die Neuerungen von Alaska zu benutzen, die sie die letzten Jahre über programmiert haben? Du kettest Dir Probleme ans Bein, die längst nicht mehr existieren! Geh auf die aktuelle Version von Xbase++ und benutze SMTPClient()! Ist schnell, braucht keinen Aufruf per runShell mit ggf. extra Fenster (!), hat saubere Rückgabewerte und funktioniert!

Wer arbeitet heute denn noch mit einem Commandozeilen-Tool wie curl in Business-Applikationen für Kunden??? Das verwendet man doch nur zum Testen!
es grüßt

Werner

<when the music is over, turn off the lights!>
Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12754
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg
Hat sich bedankt: 15 Mal
Danksagung erhalten: 20 Mal

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von AUGE_OHR »

hi Werner,

es geht nicht um eine Email Lösung sondern um ein Tool was in Windows enthalten ist.
ich kenne CURL als "das" Tool in der UNIX Welt was Windows 10/11 on Board hat.

nun hatte erfahren das man CURL nicht nur zum Up-/Down-load nutzen kann sondern auch für Email
das scheint nun mit T-ONLINE.DE zu funktionieren aber nicht mit WEB.DE

meine Anfrage im Forum war nun wegen der Fehlermeldung ob jemand die "kennt" und mir eine Hinweis, wie Jan und Carlo, geben könnte
ich "denke" es liegt nicht an CURL sondern am "Inhalt" der Email welche nicht den Spezifikation entspricht.( X-Mailer ? )
gruss by OHR
Jimmy
Benutzeravatar
Werner_Bayern
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2008
Registriert: Sa, 30. Jan 2010 22:58
Wohnort: Niederbayern
Hat sich bedankt: 20 Mal
Danksagung erhalten: 43 Mal

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von Werner_Bayern »

AUGE_OHR hat geschrieben: Sa, 02. Jul 2022 17:02 hi,

ich versuche CURL.EXE für EMAIL zu verwenden.
es geht nicht um eine Email Lösung sondern um ein Tool was in Windows enthalten ist.
ich kenne CURL als "das" Tool in der UNIX Welt was Windows 10/11 on Board hat.
Du schreibst das im Forum Xbase++ / Allgemeine Fragen... #-o

Es geht also gar nicht um Xbase++?
es grüßt

Werner

<when the music is over, turn off the lights!>
ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2415
Registriert: Mi, 28. Jul 2010 17:16
Hat sich bedankt: 11 Mal
Danksagung erhalten: 52 Mal

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von ramses »

AUGE_OHR hat geschrieben: So, 03. Jul 2022 22:24 ich "denke" es liegt nicht an CURL sondern am "Inhalt" der Email welche nicht den Spezifikation entspricht.( X-Mailer ? )
Es ist nicht mal den Header "X-Mailer" an sich sondern die Wort die darin stehen. Leider lassen sich die "Spam-Filter" Anbieter nicht in die Karten schauen und lassen dich Recht im Dunkeln tappen was die Ursache für die Spambewertung ist. Mir gab damals ein Angestellter eines Providers den Tip ich solle doch mal den Header prüfen. Es war dann der erwähnte Eintrag. Eintrag raus oder Text durch was anderes ersetzt und gut war's.
Valar Morghulis

Gruss Carlo
Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 14381
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Hat sich bedankt: 19 Mal
Danksagung erhalten: 57 Mal
Kontaktdaten:

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von Jan »

Werner_Bayern hat geschrieben: So, 03. Jul 2022 2:22was hältst du davon, endlich mal all die Neuerungen von Alaska zu benutzen, die sie die letzten Jahre über programmiert haben? Du kettest Dir Probleme ans Bein, die längst nicht mehr existieren! Geh auf die aktuelle Version von Xbase++ und benutze SMTPClient()! Ist schnell, braucht keinen Aufruf per runShell mit ggf. extra Fenster (!), hat saubere Rückgabewerte und funktioniert!
Moin Werner,
da sprechen meines Wissens zwei Punkte gegen:
  • Jimmy hat kein Xbase++ 2.0 (zumindest nicht offiziell)
  • Jimmy programmiert wohl so das sein Code sowohl unter Xbase++ und Harbour läuft. Nur in Xbase++ vorhandene Funktionen scheiden also aus.
Abgesehen davon stimme ich Dir natürlich absolut zu. Wenn Alaska schon eine Funktion mitliefert, die stabil, schnell, und sehr auskunftsfreudig ist, warum die nicht nutzen? Ich selber habe gerade dieses Wochenende bei meinem Hauptkunden endlich blat durch SMTPClient abgelöst. blat hat viele Jahre einen sehr guten Dienst getan. Aber inzwischen geht es halt auch besser.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.
ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2415
Registriert: Mi, 28. Jul 2010 17:16
Hat sich bedankt: 11 Mal
Danksagung erhalten: 52 Mal

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von ramses »

Jan hat geschrieben: Mo, 04. Jul 2022 7:18 Wenn Alaska schon eine Funktion mitliefert, die stabil, schnell, und sehr auskunftsfreudig ist, warum die nicht nutzen? Ich selber habe gerade dieses Wochenende bei meinem Hauptkunden endlich blat durch SMTPClient abgelöst.
Absolut, genial die Funktion. In meinen Augen und meinem Aufgabenbereich finde ich diese Funktion eine der besten Neuerungen ...
Valar Morghulis

Gruss Carlo
Benutzeravatar
Tom
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 8903
Registriert: Do, 22. Sep 2005 23:11
Wohnort: Berlin
Hat sich bedankt: 57 Mal
Danksagung erhalten: 231 Mal
Kontaktdaten:

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von Tom »

da sprechen meines Wissens zwei Punkte gegen:

Jimmy hat kein Xbase++ 2.0 (zumindest nicht offiziell)
Na ja, das ist nicht wirklich ein Argument. Xbase++ 1.9SL1 ist von 2009, das ist dreizehn Jahre her, und in der Welt der Full-Stack-Entwicklung sind das normalerweise gleich mehrere Generationen.

Aber Jimmy hat ja auch keine Xbase-Support angefragt, sondern Hilfe zu CURL. Das Unterforum ist falsch gewählt.
Herzlich,
Tom
Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12754
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg
Hat sich bedankt: 15 Mal
Danksagung erhalten: 20 Mal

Re: CURL.EXE Windows 10/11 und WEB.DE

Beitrag von AUGE_OHR »

hi,

wie Jan schon sagte nutze ich noch Xbase++ v1.9 in meinen alten Apps.

als Individual-Entwickler brauche ich die neusten "Technik" um mich gegen die starke Konkurrenz zu verteidigen.
da spielt die Zeit eine Rolle und ich wollte nicht mehr "warten" auf Alaska wie es mit Xbase++ weiter geht.

sei einigen Jahren verwende ich nun harbour mit der HMG Constribution (free) und FiveWin (pay for Support)
es ist für mich eine völlig neue Welt mit so vielen Möglichkeiten.

während HMG mit Function und Macro eher für Cl*pper User geeignet ist wird für FiveWin OOP Kenntnisse verlangt.
FiveWin hat CLASS WebUI2 seit letztem Jahr und CLASS WebView2 ist auch für HMG rechtzeitig, als Ersatz für IE Webbrowser2, erhältlich.

wenn ihr das HMG oder FiveWin Forun besucht dann werdet Ihr sehen welche Fragen die User z.Z. stellen.
vermutlich werden Xbase++ User die selben Fragen stellen wenn sie in der Zukunft WebUI2 und WebView2 bekommen

ein Blick über den "Teller-Rand" lohnt sich schon um zu sehen was die "anderen" machen.

---

zurück zum Thema

meine alten Xbase++ App "pflege" ich natürlich weiterhin
dort habe ich auch CDO zum senden von Errorlog eingebaut.

nun hat WEB.DE TLS umgestellt und CDO scheint nicht mehr zu funktionieren.
also habe ich nach einen Ersatz gesucht und dafür schien CURL.EXE geeignet.

btw. Aufruf per ShellExecute() mit SW_HIDE also keine CMD-Box zu "sehen"

leider "reagiert" WEB.DE nicht wie gewünscht, mit "anderen" Provider wie T-ONLINE.DE funktioniert es ... hm
daraus ist nun meine Anfrage im Forum geworden weil es für mich eine Xbase++ Frage ist.

p.s.
ich habe es inzwischen auf einen anderen Provider umgestellt und damit funktioniert CDO wieder.
gruss by OHR
Jimmy
Antworten