ADS-Local Fehler unter Xbase 2.0 [erledigt]

Advantage Database Server

Moderator: Moderatoren

Antworten
ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1640
Registriert: Mi, 28. Jul 2010 17:16

ADS-Local Fehler unter Xbase 2.0 [erledigt]

Beitrag von ramses » Mi, 08. Jul 2015 19:34

Hallo

unter xbase 1.9X konnte mit

Code: Alles auswählen

            
            oSession1 := dACSESSION():NEW( "DBE=ADSDBE;SERVER=C:\ENERGIE;ADS_LOCAL_SERVER") 
auf der lokalen HD mit den Funktionen des ADS-Servers gearbeitet werden. (ADSLOC32.DLL simuliert hier den ADS Server)

Mit Xbase 2.0 funktioniert dies nicht mehr. Fehlercode: 5381 der nicht dokumentiert ist.

ist dieses Problem bekannt?

Cu Carlo
Valar Morghulis

Gruss Carlo

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1640
Registriert: Mi, 28. Jul 2010 17:16

Re: ADS-Local Fehler unter Xbase 2.0 [erledigt]

Beitrag von ramses » Do, 09. Jul 2015 12:57

Hallo

auf dem "Problem"-System ist TC installiert.

Auf einem System ohne TC läuft es wie früher einwandfrei.

ADS_LOCAL_SERVER läuft anscheinend nicht wenn TC zugegen ist.



Cu Carlo
Valar Morghulis

Gruss Carlo

Benutzeravatar
nightcrawler
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 336
Registriert: Di, 24. Apr 2012 16:33
Wohnort: 72184 Weitingen
Kontaktdaten:

Re: ADS-Local Fehler unter Xbase 2.0 [erledigt]

Beitrag von nightcrawler » Do, 09. Jul 2015 13:25

ramses hat geschrieben:Hallo
auf dem "Problem"-System ist TC installiert.
Sicher mit dem Fehlercode? Bei Terminal Betrieb kommt eigentlich:
http://devzone.advantagedatabase.com/dz ... ricted.htm
--
Joachim
Joachim Dürr Softwareengineering
https://www.jd-engineering.de

ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 1640
Registriert: Mi, 28. Jul 2010 17:16

Re: ADS-Local Fehler unter Xbase 2.0 [erledigt]

Beitrag von ramses » Do, 09. Jul 2015 22:01

Hallo Joachim

oh Schande über mich..... 5185 ist natürlich die Zeilennummer der DACSession() Zeile im Programm.
Der Fehlercode ist 5381 und der ist nicht dokumentiert.

Cu Carlo
Valar Morghulis

Gruss Carlo

Benutzeravatar
ingo
Cut&Paste-Entwickler
Cut&Paste-Entwickler
Beiträge: 49
Registriert: Fr, 19. Okt 2007 10:20
Wohnort: Lüneburg
Kontaktdaten:

Re: ADS-Local Fehler unter Xbase 2.0 [erledigt]

Beitrag von ingo » Di, 11. Aug 2015 14:28

Moin Allerseits,
ich habe auch auf - bisher genau einem - Client den nicht dokumentierten Fehler 5381. (Nach Update auf XBase 2.0.575, List&Label 20.004)
Was ist "TC" - der Total Commander? Der wäre jedenfalls auf dem System installiert.
Hat jemand eine Idee dazu?
Danke!
Schönen Gruß, Ingo

Benutzeravatar
ingo
Cut&Paste-Entwickler
Cut&Paste-Entwickler
Beiträge: 49
Registriert: Fr, 19. Okt 2007 10:20
Wohnort: Lüneburg
Kontaktdaten:

Re: ADS-Local Fehler unter Xbase 2.0 [erledigt]

Beitrag von ingo » Di, 11. Aug 2015 15:15

Nachtrag: nach einigem Ausprobieren habe ich die Lösung:

In der ADS.INI müssen folgende Angaben vollständig sein:
[DRIVES]
// Laufwerksverknüpfung angeben, z.B.:
Q:=\\MyServer\Freigabename

// Server-IP und LAN-PORT angeben, z.B.:
[MyServer]
LAN_IP=192.168.123.1
LAN_PORT=2069
Schönen Gruß, Ingo

Antworten