Probleme mit web.de und gmx.de [ERLEDIGT]

Alles was nicht wirklich Programmierung ist, aber auch nicht Plaudereien im Raucherraum

Moderator: Moderatoren

Antworten
Benutzeravatar
Bertram Hansen
Foren-Moderator
Foren-Moderator
Beiträge: 914
Registriert: Di, 27. Sep 2005 8:55
Wohnort: 51379 Leverkusen
Hat sich bedankt: 13 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Probleme mit web.de und gmx.de [ERLEDIGT]

Beitrag von Bertram Hansen »

Hallo an alle,

seit ein paar Tagen werden einige eMails nicht mehr an meine web.de und gmx.de Adresse gesendet. Probeweise habe ich mir bei mail.de eine Adresse eingerichtet. Und dort kommen die eMails einwandfrei an.

Code: Alles auswählen

*** MAILVERSAND FEHLERBERICHT ***

Die E-Mail wurde eingeliefert am Donnerstag, 11. Februar 2021 10:21:38 +0100 (CET)
von Host xxx.de. <- von mir geändert

Betreff: Rechnung: 096531
Absender: xxx@yyy.de  <- von mir geändert

Der Mailversand zum folgenden Empfänger ist endgültig gescheitert:

zzz@web.de   <- von mir geändert
   Letzter Fehler: 554 5.0.0 
   Erklärung: host mx-ha03.web.de [212.227.15.17] said: Transaction failed Reject due 
              to policy restrictions. For explanation visit 
              https://web.de/email/senderguidelines?ip=81.169.146.166&c=
              hi

   Auszug aus dem Session-Protokoll:
   ... während der Kommunikation mit dem Mailserver mx-ha03.web.de [212.227.15.17]:
   >>> DATA (EOM)
   <<< 554 Transaction failed Reject due to policy restrictions. For 
       explanation visit 
       https://web.de/email/senderguidelines?ip=81.169.146.166&c=hi
Ich bin für jeden Tipp dankbar.
:wave:
Gruß Bertram
http://www.tobax.de
Mitglied der XUG Cologne
Mitglied der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e.V.

Solange Kakaobohnen an Bäumen wachsen ist Schokolade Obst!
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15796
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Hat sich bedankt: 34 Mal
Danksagung erhalten: 26 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Martin Altmann »

Moin,
Du hast die genannte URL besucht und Dir die folgenden Infos angeschaut?
Guidelines:
  • Make sure that your mail server and client time and date are correctly set as specified in RFC 5322.
  • Ensure that the following email headers included in your message are syntactically correct: Date, From, Sender, To.
  • Make sure that the following headers included in your email are limited to just one each: BCC, CC, Date, From, Sender, Subject, To.
  • Immediately remove hard bounced email addresses from your mailing list.
  • Make sure your mail server has a static IP address.
  • Ensure you have valid DNS records of your domain pointing to your IP address and valid reverse DNS records of your IP address pointing to your domain. You can check your DNS configuration here.
  • Verify that your domain has a properly configured MX or A record. You can check your MX configuration here.
  • Ensure your email server always sends a valid HELO/EHLO value (the fully-qualified domain name) as specified in RFC 5321. You can check your HELO here.
  • Verify that your mail server IPs are not listed on one of the Spamhaus.org lists.
Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Bertram Hansen
Foren-Moderator
Foren-Moderator
Beiträge: 914
Registriert: Di, 27. Sep 2005 8:55
Wohnort: 51379 Leverkusen
Hat sich bedankt: 13 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Bertram Hansen »

Ja das habe ich.

Hintergrund:
Ich teste gerade aus unserer Software den Versand von eMails mit Rechnungen. Zum testen habe meine web.de und gmx.de Adressen verwendet. Und damit funktioniert es jetzt nicht mehr. Wenn ich ein eMail-Adresse bei mail.de oder eine Firmen eMail-Adresse verwende, dann kommt die eMail einwandfrei an.

Ich ändere am Aufbau der eMail doch nichts, wenn ich nur eine andere eMail-Adresse von web.de oder gmx.de verwende.
:wave:
Gruß Bertram
http://www.tobax.de
Mitglied der XUG Cologne
Mitglied der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e.V.

Solange Kakaobohnen an Bäumen wachsen ist Schokolade Obst!
Benutzeravatar
Marcus Herz
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 465
Registriert: Mo, 16. Jan 2006 8:13
Wohnort: Allgäu
Hat sich bedankt: 17 Mal
Danksagung erhalten: 71 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Marcus Herz »

So wie ich das sehe, vedrsuchts du über deinen WEB account die Mail zu versenden. Ich kann mich erinnern, dass da timeouts eingebaut sind, wenn man zuoft von außen auf die mails zugreift. die wollen, dass man über ihr web ins mail geht und die werbung verkaufen. es gibt da ein maximum je 15 min fenster
Gruß Marcus

Es gibt keine Grenzen, aber du kannst welche ziehen.
Benutzeravatar
Bertram Hansen
Foren-Moderator
Foren-Moderator
Beiträge: 914
Registriert: Di, 27. Sep 2005 8:55
Wohnort: 51379 Leverkusen
Hat sich bedankt: 13 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Bertram Hansen »

Nein, für den Versand habe ich mir mir einen Account bei strato angelegt. Nur die Empfänger Adresse ist eine Web.de Adresse.
:wave:
Gruß Bertram
http://www.tobax.de
Mitglied der XUG Cologne
Mitglied der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e.V.

Solange Kakaobohnen an Bäumen wachsen ist Schokolade Obst!
Benutzeravatar
Bertram Hansen
Foren-Moderator
Foren-Moderator
Beiträge: 914
Registriert: Di, 27. Sep 2005 8:55
Wohnort: 51379 Leverkusen
Hat sich bedankt: 13 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Bertram Hansen »

Jetzt wird es noch ein wenig merkwürdiger.

Ich kann in unserer Software über 2 unterschiedliche Wege eine eMail versenden.
- über CreateObject("CDO.Message")
- und über SEE4XB von MarshallSoft

Wenn ich die eMails über CDO.Message versende, dann kommen die einwandfei an. Nur wenn ich diese über SEE4XB versende, kommen die an meine Web.de Adresse nicht an.
Ich ändere nur die Versandart (CDO.Message oder SEE4XB), an den Empfängeradressen oder dem eMailaufbau mit Dateianhang ändere ich nichts.
:banghead:
:wave:
Gruß Bertram
http://www.tobax.de
Mitglied der XUG Cologne
Mitglied der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e.V.

Solange Kakaobohnen an Bäumen wachsen ist Schokolade Obst!
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15796
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Hat sich bedankt: 34 Mal
Danksagung erhalten: 26 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Martin Altmann »

Poste mal den Code.
Ich vermute, du setzt header nicht, die bei cdo automatisch ergänzt werden.

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Bertram Hansen
Foren-Moderator
Foren-Moderator
Beiträge: 914
Registriert: Di, 27. Sep 2005 8:55
Wohnort: 51379 Leverkusen
Hat sich bedankt: 13 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Bertram Hansen »

Martin, da muss ich erstmal in Ruhe etwas zusammenstellen.
:wave:
Gruß Bertram
http://www.tobax.de
Mitglied der XUG Cologne
Mitglied der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e.V.

Solange Kakaobohnen an Bäumen wachsen ist Schokolade Obst!
Benutzeravatar
Bertram Hansen
Foren-Moderator
Foren-Moderator
Beiträge: 914
Registriert: Di, 27. Sep 2005 8:55
Wohnort: 51379 Leverkusen
Hat sich bedankt: 13 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Bertram Hansen »

Wenn ja generell über SEE4XB etwas falsch wäre, dann dürfte doch keine eMail ankommen. Es passiert nur bei den web.de und gmx.de Empfängern.
:wave:
Gruß Bertram
http://www.tobax.de
Mitglied der XUG Cologne
Mitglied der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e.V.

Solange Kakaobohnen an Bäumen wachsen ist Schokolade Obst!
Benutzeravatar
nightcrawler
Rekursionen-Architekt
Rekursionen-Architekt
Beiträge: 458
Registriert: Di, 24. Apr 2012 16:33
Wohnort: 72184 Weitingen
Hat sich bedankt: 1 Mal
Danksagung erhalten: 35 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von nightcrawler »

Wie Martin schon geschrieben hat: Header
Sende mal über beide Wege die Email an einen Provider, der mit beiden funktioniert. Dann lasse Dir beim Empfänger den Quelltext der Email anzeigen und vergleiche auf die Unterschiede.
--
Joachim
Joachim Dürr Softwareengineering
https://www.jd-engineering.de
Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15796
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Hat sich bedankt: 34 Mal
Danksagung erhalten: 26 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Martin Altmann »

Bertram,
einzelne Anbieter (web.de und gmx.de ist eins!) ziehen allmählich die Daumenschrauben enger.
Nicht jeder ist bei allen Verstößen gegen die RFCs gleich pingelig.

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Benutzeravatar
Klaus Schuster
Foren-Moderator
Foren-Moderator
Beiträge: 315
Registriert: Do, 24. Jan 2008 10:01
Wohnort: 90762 Fürth
Hat sich bedankt: 4 Mal
Danksagung erhalten: 5 Mal

Re: Probleme mit web.de und gmx.de

Beitrag von Klaus Schuster »

Moin Bertram,

vor geraumer Zeit hatte ein Kunde von mir auch Probleme mit den selben Providern. Nach zwei monatiger Suche haben wir zufälliger Weise festgestellt, dass ein Punkt zuviel in der Absenderadresse stand. Andere Provider haben diesen wohl entfernt und die Mails zugestellt. Denkbar wäre auch, dass der Server in der Absenderadresse ein anderer ist, als der über den versandt wird. Viel Erfolg, es war sehr nervig den Fehler zu finden.
Gruß Klaus
Benutzeravatar
Bertram Hansen
Foren-Moderator
Foren-Moderator
Beiträge: 914
Registriert: Di, 27. Sep 2005 8:55
Wohnort: 51379 Leverkusen
Hat sich bedankt: 13 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Bertram Hansen »

Schon mal vielen Dank für die Hinweise.
Ich weder mich in den nächsten Tagen mal in Ruhe damit beschäftigen.
:wave:
Gruß Bertram
http://www.tobax.de
Mitglied der XUG Cologne
Mitglied der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e.V.

Solange Kakaobohnen an Bäumen wachsen ist Schokolade Obst!
ramses
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2272
Registriert: Mi, 28. Jul 2010 17:16
Hat sich bedankt: 10 Mal
Danksagung erhalten: 39 Mal

Re: Probleme mit web.de und gmx.de

Beitrag von ramses »

Hallo Bertram

mit see4xb hatte ich schon grosse Probleme mit unklaren Fehlermeldungen.
Das Problem war damals dass see4xb im Header Felder nutzte die der Provider ohne Warnung als unzulässig gesetzt hatte.
z.B. wurden von see4xb im Header einige Zeilen mit Werbung und auch der Name Lizenznehmers mit gesendet.

Seit der Mailversand mit den Xbase Funktionen abgewickelt wird läuft dies schneller und auch Problemlos.

Seit diesem Jahr muss mit den Providern die ich von meinen Kunden kenne auch der Helo, Mail-From Name mit den genutzen Account genau übereinstimmen. Sonst gibt es ganz unterschiedliche Fehlermeldungen.
Valar Morghulis

Gruss Carlo
Benutzeravatar
Bertram Hansen
Foren-Moderator
Foren-Moderator
Beiträge: 914
Registriert: Di, 27. Sep 2005 8:55
Wohnort: 51379 Leverkusen
Hat sich bedankt: 13 Mal
Danksagung erhalten: 8 Mal
Kontaktdaten:

Re: Probleme mit web.de und gmx.de

Beitrag von Bertram Hansen »

Großer Dank an Martin =D>

Es lag an der Absenderadresse. Dort hatte ich den Firmennamen mit Umlauten und die E-Mailadresse verwendet z.B. "Getränke XYZ <info@getraenke-xyz.de>".
Den Firmennamen wandele ich jetzt vorher mit der Funktion XseeQuoteBuffer() um.
:blob8:
:wave:
Gruß Bertram
http://www.tobax.de
Mitglied der XUG Cologne
Mitglied der XUG Osnabrück
Beisitzer des Deutschsprachige Xbase-Entwickler e.V.

Solange Kakaobohnen an Bäumen wachsen ist Schokolade Obst!
Antworten