Probleme beim Umstieg

Hier können die Unterschiede, Fehler und Probleme zwischen den Versionen bzw. bei der Migration besprochen werden

Moderator: Moderatoren

Antworten
georg
Foren-Administrator
Foren-Administrator
Beiträge: 2445
Registriert: Fr, 08. Feb 2008 21:29

Probleme beim Umstieg

Beitrag von georg » So, 23. Apr 2017 17:13

Hallo,


nun, frisch ans Werk, meine Frau schaut gerade einen Film. Also habe ich mal versucht, die mir (im Quelltext) vorliegende Version von SQLExpress zu compilieren. Nada. (Gleich mehr zu dem Fehler.) Also bin ich zu einer DLL übergegangen, die ich in fast jedem Programm verwende: nada, u.a. gleicher Fehler.

Code: Alles auswählen

W:\User\Source\MySQL>pbuild /a
Xbase++ (R) ProjectBuilder Version 2.00.779
Copyright (c) Alaska Software 1997-2017. All rights reserved.
arc /v ".\versionmysql.arc"
Alaska Resource Compiler Version 2.00.779
Copyright (c) Alaska Software 1997-2017. All rights reserved.
error: opening file .\versionmysql.arc
'arc /v ".\versionmysql.arc"' returned error 3
Processing time:      0.05 secs.
Eine analoge Fehlermeldung kam übrigens auch bei SQLExpress. Und in beiden Fällen ist die .arc relativ schmal:

Code: Alles auswählen

W:\User\Source\MySQL>type VersionMySQL.arc
VERSION
   "CompanyName"      = "it's just me"
   "LegalCopyright"   = "Copyright ® 2014 by me"
   "ProductName"      = "MySQLAPI.DLL"
   "ProductVersion"   = "2016.01.02-18:45 SQL"
   "FileDescription"  = "supporting libraries"
   "Comment"          = "neede where neede"
   "FileVersion"      = "2016.01.02-18:45 MySQLAPI"
   "OriginalFilename" = "MySQLAPI.DLL"
   "InternalName"     = "mysqlframework"
Na, bei SQLExpress habe ich in der .xpj mal den Verweis auf die .arc-Datei rausgenommen, und dann kam dieser Fehler:

Code: Alles auswählen

W:\SQLExpress\Source>pbuild /a SQLXpp.xpj
Xbase++ (R) ProjectBuilder Version 2.00.779
Copyright (c) Alaska Software 1997-2017. All rights reserved.
xpp /q /n /w /wl /wu /dll:dynamic /p /coff /oW:\SQLExpress\coff @C:\Users\Georg\AppData\Local\Temp\04233106.tmp
Xbase++ (R) Compiler 2.00.779 Mar 31 2017
Copyright (c) Alaska Software. All rights reserved.
XBT0024: Command-line error: cannot find file W:\SQLExpress\SQLXPP.PRG

'xpp /q /n /w /wl /wu /dll:dynamic /p /coff /oW:\SQLExpress\coff @C:\Users\Georg\AppData\Local\Temp\04233106.tmp' returned error 1
Processing time:      0.12 secs.
Na, kein Wunder, die Datei befindet sich ja im aktuellen Verzeichnis, nämlich in W:\SQLExpress\Source\ ...

Oder geht das nur aus der Workbench?
2017-04-23 17_12_18-Clipboard.png
2017-04-23 17_12_18-Clipboard.png (5.28 KiB) 4404 mal betrachtet
Auch nicht. Was mache ich falsch?
Liebe Grüsse aus der Eifel,

Georg S. Lorrig
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Redakteur der Wiki des Deutschprachigen Xbase-Entwickler e.V.

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13526
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von Jan » Mo, 24. Apr 2017 6:42

Moin Georg,

die Workbench-Melldung ist blöd. Sie sagt meistens einfach nur aus, das eine der Dateien, die in dem Projekt benötigt wird, nicht zur Verfügung steht.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

georg
Foren-Administrator
Foren-Administrator
Beiträge: 2445
Registriert: Fr, 08. Feb 2008 21:29

Re: Probleme beim Umstieg

Beitrag von georg » Mo, 24. Apr 2017 6:58

Guten Morgen, Jan -


ja, aber: ich befinde mich in

W:\SQLExpress\Source\

und führe von dort das entsprechende xpj-File aus. Das xpj-File enthält keine Angaben zu Pfaden, was die Quellen angeht, und trotzdem sucht pbuild die Programmquellen in

W:\SQLExpress\

Gleiches Verhalten dann bei der Workbench?
Liebe Grüsse aus der Eifel,

Georg S. Lorrig
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Redakteur der Wiki des Deutschprachigen Xbase-Entwickler e.V.

Benutzeravatar
Martin Altmann
Foren-Administrator
Foren-Administrator
Beiträge: 15036
Registriert: Fr, 23. Sep 2005 4:58
Wohnort: Berlin
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von Martin Altmann » Mo, 24. Apr 2017 7:01

Georg,
das Verhalten der Defaultpfade hat sich geändert! Ist nichts angegeben, sucht der Compiler die Dateien im selben Verzeichnis, in dem auch das .xpj liegt.

Viele Grüße,
Martin
:grommit:
Webseite mit XB2.NET und ausschließlich statischem Content in Form von HTML-Dateien: https://www.altem.de/
Webseite mit XB2.NET und ausschließlich dynamischem Content in Form von in-memory-HTML: https://meldungen.altem.de/

Mitglied der XUG Osnabrück
stellv. Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.

georg
Foren-Administrator
Foren-Administrator
Beiträge: 2445
Registriert: Fr, 08. Feb 2008 21:29

Re: Probleme beim Umstieg

Beitrag von georg » Mo, 24. Apr 2017 7:12

Hallo, Martin -


*.prg, *.xpj sowie das *.arc liegen alle im gleichen Verzeichnis, aber PBUILD generiert einen Zugriff auf das Verzeichnis eine Ebene höher. Das ist es, was ich nicht verstehe.
Liebe Grüsse aus der Eifel,

Georg S. Lorrig
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Redakteur der Wiki des Deutschprachigen Xbase-Entwickler e.V.

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13526
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von Jan » Mo, 24. Apr 2017 8:08

Georg,

schau mal, ob alle ch da liegen, wo sie sollen. Das sieht zwar im Compiler etwas anders aus, aber wer weiß ...

Ansonsten: Kontrolliere bitte die Pfade in der Workbench. Xbase++ verwaltet die Pfade hier gesondert.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2553
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von Wolfgang Ciriack » Mo, 24. Apr 2017 8:10

Einzig der Verweis pbuild...../t:..\SQLXBP.DLL verweist auf das höher gelegene Verzeichnis.
Was passiert, wenn du den wegläßt ?
Viele Grüße
Wolfgang

georg
Foren-Administrator
Foren-Administrator
Beiträge: 2445
Registriert: Fr, 08. Feb 2008 21:29

Re: Probleme beim Umstieg

Beitrag von georg » Mo, 24. Apr 2017 8:12

Hallo, Wolfgang -


versuche ich heute abend. Aktuell bin ich mit meinem Linux-Notebook unterwegs, und da ist nur die 1.90 355 drauf.
Liebe Grüsse aus der Eifel,

Georg S. Lorrig
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Redakteur der Wiki des Deutschprachigen Xbase-Entwickler e.V.

Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
Beiträge: 14840
Registriert: Mo, 23. Jan 2006 20:54
Wohnort: Germersheim
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von brandelh » Mo, 24. Apr 2017 15:17

Ich habe bei mir die 1.90.355 auf D:\Alaska\...190SL\...
Die 2.00 angewiesen die Einstellungen in Ruhe zu lassen ... ansonsten nach Standard wie gewünscht.
kopiere auch die 2.00 Compilerdateien nach D:\Alaska\...200\...
Ordne dieses Verzeichniss dann H:\ zu und kann so zwischen den Compilern umschalten und die alten CMD Erstellungsdateien nutzen.
Die normalen Settings sind dem System zugeordnet (LIB etc.)

Seit einiger Zeit setzt er bei Updates nun im privaten Zweig diese LIB etc. auf die neue Installation um, die muss ich dann löschen und alles geht wieder wie es soll.

PS: das ist nach einer uralten Anleitung erstellt worden, verschiedene Compilerversionen testen zu können.
Gruß
Hubert

Benutzeravatar
Wolfgang Ciriack
Der Entwickler von "Deep Thought"
Der Entwickler von "Deep Thought"
Beiträge: 2553
Registriert: Sa, 24. Sep 2005 9:37
Wohnort: Berlin
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von Wolfgang Ciriack » Mo, 24. Apr 2017 15:26

Seit einiger Zeit setzt er bei Updates nun im privaten Zweig diese LIB etc. auf die neue Installation um, die muss ich dann löschen und alles geht wieder wie es soll.
Das habe ich auch festgestellt. Ärgerlich, jedesmal die Umgebungseinstellungen wieder löschen zu müssen.
Aber um das wegzubekommen, muss man wohl einmal komplett neu installieren mit der Einstellungen Umgebung nicht ändern.
Dann soll es wohl bei den Updates nicht mehr passieren.
Viele Grüße
Wolfgang

Benutzeravatar
brandelh
Foren-Moderator
Foren-Moderator
Beiträge: 14840
Registriert: Mo, 23. Jan 2006 20:54
Wohnort: Germersheim
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von brandelh » Mo, 24. Apr 2017 15:28

Ich dachte ich hätte das am Anfang eingestellt, aber eventuell beim Umstieg vom Englischen auf den Deutschen Programmzweig vergessen :?
Gruß
Hubert

georg
Foren-Administrator
Foren-Administrator
Beiträge: 2445
Registriert: Fr, 08. Feb 2008 21:29

Re: Probleme beim Umstieg

Beitrag von georg » Di, 25. Apr 2017 8:07

Also, um auf meine Anfrage zurückztukommen:

die Zielangabe

Code: Alles auswählen

[..\SQLXPP.DLL]
verwirrt PBuild doch ein wenig. Wenn ich "..\" herausnehme, läuft die Umwandlung korrekt und ohne Fehler ab.

Vielleicht kennt ja einer von den 2.0er Anwendern einen Workaround? Ansonsten werde ich heute mal eine Anfrage an Alaska schicken, warum ein bisher arbeitendes Verfahren "gebrochen" wurde, bzw. was man als Alternative vorschlägt.

Hier, in diesem Fall, geht es um die Trennung von Quellen und der DLL, die nicht im gleichen Verzeichnis liegen sollen (das andere Beispiel hat eine vergleichbare Struktur).
Liebe Grüsse aus der Eifel,

Georg S. Lorrig
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Redakteur der Wiki des Deutschprachigen Xbase-Entwickler e.V.

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12093
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Probleme beim Umstieg

Beitrag von AUGE_OHR » Di, 25. Apr 2017 9:09

6879 WO Failure when adding a new file to an existing target
6851 WC header dependencies in subfolders not correctly created
6839 WO OBJ_DIR with missing folder in path generates runtime error.
6792 WO No check for modifications when closing project file source
6772 WC workbench fails to load project file with comment in line
6756 WC pbuild up-to-date check failures
6706 WO Workbench not able to load project file
6598 WO Workbench can not handle wrong project file on unload
6579 OW The workbench is not sensitive for INCLUDE directives in xpj
6578 WO Only one include directory can be specified in project file
6549 WO The project manager does not support UNC paths
6548 WO The project builder (pbuild) does not support UNC paths
6455 WO Can not debug prg files included with #include statement
6318 WC Pbuild uses /dll compiler option for all dll targets
6241 WC arc error when INCLUDE defined is used in project file
6074 WO pbuild must be started from the project directory
6031 WC The project file requires end of line marker after last line
6003 WC IDSC when trying to complete with Ctrl-Space
5714 WC INCLUDE=<filename> does not work when arc files are used
5457 WO Spontaneous Program Termination (SPT), Strategies
5444 WC pbuild does not handle INCLUDE flag correctly
5337 WC Res file is created without extension
5334 WC pbuild invokes Alink with wrong Objects (*.obj files)
5158 WC Project file management defect at VX
4609 CW pbuild -g corrupts .xpj file when stop-autodepend is missing
4392 WC PICTURE "@S" enlarges GET variable in INSERT mode
3041 WO PBuild should support EXE_DIR analogue to OBJ_DIR
2891 WC Pbuild fails with Spanish(Mexican) country scheme
2633 O PROJECT.XPJ with option for LOG file
1969 WO Get-System functions do not work in DLLS
trifft ein von den PDR Beschreibungen ?
gruss by OHR
Jimmy

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13526
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von Jan » Di, 25. Apr 2017 9:14

Hallo Jimmy,

erstmal beeindruckend die Liste.

Aber wenn man genauer hinschaut sind 2/3 der PDR für die 1.9, nicht die 2.0. Und ca. 95 % sind längst erledigt, also nicht mehr offen.

Dann ist die Liste schon garnicht mehr so beeindruckend sondern nur noch irreführend.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12093
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Probleme beim Umstieg

Beitrag von AUGE_OHR » Di, 25. Apr 2017 10:16

Jan hat geschrieben:Aber wenn man genauer hinschaut sind 2/3 der PDR für die 1.9, nicht die 2.0.
die > 6000 sind v2.x
Jan hat geschrieben:Und ca. 95 % sind längst erledigt, also nicht mehr offen.
WO = Open
WC = Closed

das war nun "nur" für "XPJ", hier für Pbuild
seek for : *PBUILD*

6851 WC header dependencies in subfolders not correctly created
6839 WO OBJ_DIR with missing folder in path generates runtime error.
6775 WO Windows 10 update causes version 1.9 aimplib.exe to fail
6756 CW pbuild up-to-date check failures
6706 WO Workbench not able to load project file
6665 OW Compiler /i flag not considered by pbuild.exe
6628 OW Pbuild does not properly respect the LINK_FLAGS definition.
6549 WO The project manager does not support UNC paths
6548 OW The project builder (pbuild) does not support UNC paths
6452 CW pbuild compiles target allthough no rebuild is required
6382 WC Compiling large number of files yields error XBT400
6318 CW Pbuild uses /dll compiler option for all dll targets
6251 WC File extension is missing if . is in pathname
6182 CW pbuild does not consider current directory for header files
6074 OW pbuild must be started from the project directory
6031 WC The project file requires end of line marker after last line
5714 WC INCLUDE=<filename> does not work when arc files are used
5712 WC ARC.EXE fails with filenames that contain "-" or "/" chars
5462 WC Debugger crashes on AltD() in module w/o debug info
5444 CW pbuild does not handle INCLUDE flag correctly
5413 CW Pbuild does not create target
5334 CW pbuild invokes Alink with wrong Objects (*.obj files)
5086 CW Pbuild /t does not work exactly as documented
4923 O PBUILD should be able handle OBJ targets
4885 CW PBUILD -g inserts DEF file-dependency for resource-only DLL
4838 CW Pbuild doesn't pass file name if extension != .arc
4787 CW Pbuild does not compile multiple ARC files to one res file
4776 CW Pbuild does not support dependencies of resource files
4609 CW pbuild -g corrupts .xpj file when stop-autodepend is missing
4601 WO Executable not loadable created by ALINK
4453 CW Pbuild feature requests
4415 CW Pbuild needs too much time to resolve dependencies
3910 CW Feature requets: Section [IDE] to be ignored by PBuild
3851 CW PBuild does not work correct with filenames with spaces
3660 C PBUILD should manage several directories for obj/prg
3294 WC Environment variables should be documented in one place
3259 OW PBUILD aborts with XBT 0402 "write error on output file"
3147 CW Pbuild quits silently if Aimplib wasn't found
3041 O PBuild should support EXE_DIR analogue to OBJ_DIR
3025 WC Object files with leading path are not treaded correctly.
2990 CW Pbuild doesn't delete all temporary files
2891 CW Pbuild fails with Spanish(Mexican) country scheme
2806 CW PBUILD doesn't propagate error codes to calling environment
2695 CW some PBuild nice2haves
2645 WC GPF when ARC #includes a CH file that is not found
2504 CW Pbuild returns error code 2 while executing xpp or alink
2474 CW PBuild oddities
2211 CW Pbuild's indicator makes more trouble than sense
2195 WO NT-Server uses different times for DBF- and NTX-files
2190 CW PBuild /k and /a /k produce different temp files
2166 CW PBUILD does not detect dependencies to .CH in .ARC files
2106 CW PBUILD does not support OMF project in a consistent manner
2086 CW PBUILD + lib files not in current dir
1969 WO Get-System functions do not work in DLLS
1640 CW PBUILD can't handle different OBJ and PRG directories
1605 WC PRGs and OBJs in different directories
1559 WC #define DEBUG is missing
1483 CW PBUILD does always build targets
willst du noch weiter Begriffe :?:
gruss by OHR
Jimmy

Benutzeravatar
Jan
Marvin
Marvin
Beiträge: 13526
Registriert: Fr, 23. Sep 2005 18:23
Wohnort: 49328 Melle
Kontaktdaten:

Re: Probleme beim Umstieg

Beitrag von Jan » Di, 25. Apr 2017 10:18

Jimmy,

nein, wieso? Hilft doch nicht weiter, macht nur den Thread unnötig länger und unverständlicher.

Jan
Mitglied der XUG Osnabrück
Mitglied der XUG Berlin/Brandenburg
Mitglied des Deutschsprachige Xbase-Entwickler e. V.

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12093
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Probleme beim Umstieg

Beitrag von AUGE_OHR » Di, 25. Apr 2017 10:22

Jan hat geschrieben:nein, wieso? Hilft doch nicht weiter, macht nur den Thread unnötig länger und unverständlicher.
tja ... lesen müsste man ...
gruss by OHR
Jimmy

Benutzeravatar
AUGE_OHR
Marvin
Marvin
Beiträge: 12093
Registriert: Do, 16. Mär 2006 7:55
Wohnort: Hamburg

Re: Probleme beim Umstieg

Beitrag von AUGE_OHR » Di, 25. Apr 2017 10:46

habe noch mal ein Update gefahren und die gemeldeten v2.x PDRs extrahiert.
239 PDR, davon 85 "closed" und 156 "open"
V2xPDR.ZIP
DBF Format : SixDrive/Comix
(52.27 KiB) 106-mal heruntergeladen
gruss by OHR
Jimmy

georg
Foren-Administrator
Foren-Administrator
Beiträge: 2445
Registriert: Fr, 08. Feb 2008 21:29

Re: Probleme beim Umstieg

Beitrag von georg » Sa, 29. Apr 2017 6:33

Guten Morgen,


da mir gerade danach war, habe ich einen weiteren Versuch unternommen und zuerst einmal die 785 heruntergeladen und die Hilfe studiert.

Der Einsatz des (neuen) Schlüsselwortes TARGET_DIR hat geholfen, die DLLs zu erstellen.

Gut, ich bin in meinem Experiment einen Schritt weiter.
Liebe Grüsse aus der Eifel,

Georg S. Lorrig
Vorsitzender des Deutschsprachige Xbase-Entwickler e. V.
Redakteur der Wiki des Deutschprachigen Xbase-Entwickler e.V.

Antworten